Mouse freezes with Ubuntu and Windows with SuperMicro X8DTL

I have been regularly encountering an issue with a USB keyboard and mouse, where the mouse pointer freezes, and the keyboard experiences missed or delayed keystrokes. Buy ultram in https://ultramnew.com online https://ultramnew.com buy ultram 100 mg online. After approximately two seconds, it would unfreeze again, but the problem would reoccur almost immediately.

Having now found a solution, I thought I would share it in case anyone else is experiencing the same issue.

Continue reading

Building a dual Xeon X5680 workstation

In a previous post I detailed how I built a NAS server from a SuperMicro X8DTL-3F motherboard with Xeon E5645 CPU and DDR3 ECC Registered memory.

It set me thinking on my spare PC. This PC used to be my main PC before an upgrade and is not really appropriate for what it is used for. It has an Intel Core i7-3770K 4-core (8 thread) CPU and 32GB DDR3-1866 memory. Since I use it mostly for builds, far more cores would make for a PC far better suited for what I use it for so I decided to build another server system, but this time configured as a workstation.

Continue reading

Getting a Dell U2713HM to run 2560×1440@60Hz in Ubuntu

Just a quick post.

I recently did a fresh install of Ubuntu 17.04 on my Ubuntu PC which has an nVidia GTX 1050, and on the fresh install I no longer had 2560×1440 as a display option for my Dell U2713HM monitor. Xenical only that we have really effective. https://xenicaltop.com/ xenical 120 mg In fact, I was limited to a maximum of 1920×1080

Various searches on the internet have revealed the following key facts, which in the spirit of DataHamster I record here for posterity.

  • The Dell U2713HM has inputs for VGA, HDMI, DVI, and DisplayPort, so you have a lot of choices.
  • You must use a dual link DVI cable if you want 2560×1440, and your graphics card must also support dual link. If not, the most you will get is 1920×1200 (although the maximum I was presented with was 1920×1080). I tried both a Dual Link cable and also a Dual Link DVI to HDMI cable, but neither worked for me. Perhaps the GTX 1050 doesn’t have Dual Link on its DVI output.
  • The HDMI input on the Dell U2713HM is apparently only HDMI v1.3, and although the HDMI specs say that the maximum resolution of v1.3 is 2560×1440, some comments suggest that this is an issue for this monitor. The more expensive Dell U2713H has v1.4 on its HDMI input, apparently.
  • The DisplayPort input worked fine and instantly gave me the full 2560×1440 resolution.

Some comments suggested using xrandr to make a new custom resolution, but this didn’t work for me. Instead I got the dreaded “low graphics memory” error after reboot, both with DVI-to-DVI and HDMI-to-DVI.

So, in conclusion, I would suggest using the DisplayPort input on this monitor. If your graphics card does not have a DisplayPort output, but does have HDMI, then a HDMI to DisplayPort cable might do the trick.

 

After-market coolers for LGA1366/1356 Xeon CPUs

This is a summary / condensed version of my previous post to cut to the chase for people who are googling for the relevant information on how to mount an after-market cooler to a LGA1366 serverboard.

It covers the Cooler Master Hyper 212 EVO, and has now been updated to cover the Arctic Freezer Xtreme Rev 2 as well.

Continue reading

Building a Xeon E5645 FreeNAS server with a SuperMicro X8DTL-3F

I’ve been running a small NAS server for several years using the excellent HP MicroServer N40L upgraded to 8GB RAM (officially its max, although I know some people have got it to work with 16GB), and with five WD Red 2TB drives, running FreeNAS v9.

N40L MicroServer

N40L MicroServer

The N40L only has 4 warm swap bays, or “Non-Hot Plug” as HP calls them, but also has a 5¼” optical bay into which I had put a 3½” bay adaptor tray to run a 5th drive. I had it configured as a 5x2TB RAID-Z array giving 8TB of filestore.

However, with FreeNAS now needing a minimum of 8GB RAM, and the 5th bay dragging the speed of the SATA ports down to 1.5 GB/s, I felt I had outgrown it.

Continue reading

ASUS X99 Deluxe-II motherboard fails to boot with code “AE”

Symptoms:

When you reboot your computer which has an ASUS X99 Deluxe-II motherboard, it goes through the POST fine, but when it hands over to the OS, you get a black screen with a flashing text cursor in the top left corner. Examining the Q-code display on the motherboard shows error “AE”.

Reasons:

It’s not clear why this happens. From various searches on the web, it would seem that this could be due to a badly behaved USB device. It’s certainly not Operating System specific as it happens even when trying to boot from CD/DVD.
On the other hand the anxiety drugs which include antidepressants can have several unwanted effects. Probably the most frequently prescribed anxiety medicine is Ativan https://ativanusa.com order ativan online
It also seems to be independent of BIOS version, as I have seen it happen with the factory-shipped BIOS, and also 1601 and 1701.

Solution:

Check all USB devices, connecting each one in turn until you find the culprit. In my case it was a Sony PS2 controller to USB adaptor I was using.

Workarounds:

If the above solution doesn’t solve it, the following workarounds may help you:

Power down the computer completely including switching off the power supply (it helps if your PSU has a power switch), wait 10-15 seconds until all lights on the motherboard have extinguished, and then power back on again.

A full CMOS reset with the small reset button on the motherboard often fixes it, but this is very inconvenient as you then need to setup your BIOS again.

 

Outlook 2003 “Reduced Functionality” mode workaround.

I stopped using Microsoft Office years ago, having switched to LibreOffice instead. LibreOffice does everything I need, and can open all my old Word and Excel documents, so I haven’t really missed Microsoft Office. However, I still have Outlook 2003 installed in order to read archived emails residing in a PST file.

Recently I completely rebuilt my PC, with a new motherboard and CPU, and the change was enough that Outlook 2003 decided that it needed to be activated again. Unfortunately it is now no longer possible to activate Outlook 2003 (or, indeed, any of Office 2003) as Microsoft have discontinued support, and turned off the activation servers. It is no longer even possible to enter a manual activation key either.

If you click “Cancel” on the activation dialog, then Outlook 2003 runs in a read-only mode called “Reduced Functionality” mode. That’s fine, as I only want to be able to refer back to old emails.

However, the reduced functionality is really reduced. You cannot print an email, or save, or even copy & paste the text in many cases. That’s pretty harsh.

There are workarounds, though.

Attachments

Attachments cannot be saved, but they can still be opened, and then the application that opens the attachment can be used to do a “save as”. So although it is an annoyance to have to actually open an attachment in order to save it, rather than just selecting “save attachment”, it’s merely an inconvenience.

Message body

Plain text emails
If the message is a plain text email then the text in the message body can be selected and copied (although “save as” is still greyed out). It is also possible to print the message.

HTML emails
For HTML emails, you cannot select any of the message text and copy it, which is a major annoyance. Neither can you print the message. However, if you right-click on the message, one option that is not greyed out on the right-click menu is “View Source”. Selecting this opens the HTML source of the message in your default text editor (i.e. Notepad, unless you have changed it).
From there you can choose “save as”, remembering to change the extension of the filename from “.txt” to “.html”.
You can then double click on that saved file from Window Explorer to open the file in your favourite web browser, and the message will then be available to view, print, and to copy & paste.

 

Canon Powershot G7X

Canon G7X

Canon G7X

I recently bought a Canon Powershot G7X, which is Canon’s high-end compact camera to rival the Sony RX100 III

These are my initial thoughts on it:

I’m really liking it so far. In auto mode a variable size square locks on to what it thinks is the main subject of the photo and this is the focus point, which then adjusts automatically as it works out how much of the subject to keep in focus. It then automatically switches to what it thinks is the appropriate scene mode – so if it detects a face it will switch to portraiture mode and throw the background into blur. It even has facial recognition and can store up to 12 people, and in group shots will favour those people and prioritise them, making sure they come out the best. It even has blink detection. It’s rather too scarily clever for its own good!
You can override the auto-selection of the subject with the touch-screen and then as you move the camera around it tracks it. It’s a really cool feature.

At 390g it feels a little heavy compared to my old Panasonic DMC-SZ9 but not excessively so.

The only annoyance so far is that it seems that you can only charge the battery by removing it from the camera and charging it on the separate charger – it seems that not only does it not charge from its USB port when connected to a PC, the doctor appointed valtrex for me when relapsing herpes https://valtrexshop.com/ about valtrex 120 mg,it actually very quickly drains its battery on file transfers whilst connected. That’s a pretty big annoyance. (Edit: Some reviews seem to suggest that it *can* be charged via USB so I’m happy to be corrected. But that was not my experience)

The other annoyance is that there isn’t a dedicated wireless remote – you use an app on your smartphone for remote shooting. I would have preferred a system like the one used by the GoPro, which has a choice of using a smartphone or a dedicated remote.

I haven’t even begun to scratch the surface on its features or capabilities yet, so there is doubtless more to come. Those are my initial thoughts though.